Having difficulties with Yousician Piano? Found a bug in the game? Post it here.
By liurn

I'm using a Komplete Kontrol S61 plugged in USB + Focusrite Scarlett 2i4 (Windows default audio device) + Win 7.

I'm not having any issue playing the correct keys but my keyboard's playback is not in tune with the song's playback. I'd say my keyboard is almost 1 tone lower than the track.

I'm calibrating before playing the song but it's not solving the issue.

Attached my settings in Yousician. It's on MIDI Input. I also tried Focusrite USB ASIO: when I play while in the Settings menu, it works exactly the same (same sound, same latency, same tone). After playing a song, settings go back on their own to Midi Input.


Is there a way to make sure my keyboard and Yousician are in tune? Right now, I can only play when I mute the song (and that is not doable in the Perform mode).
By BrunoC6

As far as I can see Komplete Kontrol S61 has an octave switch option. Could it be so that you are playing the right notes in a different octave?

If you make sure your keyboard's "middle C" is a C4 then you should simply need to follow the notes on the screen and it should sound right.

Let me know if this helps!
By liurn
Hi Bruno,

I don't think it's related to this octave switch, since the difference between the soundtrack and my piano is somewhere between 1 tone and 1.5 tone.

Any other idea?

By AnttiH
The difference between 44100 and 48000 sample rates is about 1.47 semitones. That might be one possible explanation for the observed pitch error. Can you find out if your audio setup is using a mixture of these rates? If so, we'd like to hear, which mismatch is actually causing this and whether it's possible to solve it within Yousician. Also, is it the Yousician synth or another soft synth which actually produces the keyboard sound? Thanks!

By AnttiH
liurn wrote:Thanks for your help Anttih. Is Yousician's sample rate 44100 or 48000?
It can use diverse sample rates. A couple of factors, starting from the main platform, are affecting this. Upon startup, Yousician checks the rates supported (or forced) by the system, and generally prefers 44100 or the closest to it for its output. Even if the system setup results in another choice, it still should work. However, problems may arise if, for example, OS audio settings change when the program is already running, or somehow the OS manages to report a sample rate which does not match its actual audio processing.

We are just implementing some further checks and robustness to the rate handling on different platforms. If you can find out the potential mismatches that may cause incorrect handling in your setup, that would be helpful for this work. Also, have you checked whether it's the song or the synth which is in correct key when the mismatch happens? We have some similar hardware here so maybe we can even replicate the scenario. Let's keep turning stones...

By maximusfixler
I'm having the same issue. My MIDI keyboard has been working fine for weeks. Now Yousician recognizes my notes as being a half-step off. It recognizes when I pay the correct note but the sound is off. I reset the computer previously and it fixed the problem but that fix is no longer working. Not sure of what to do.
long long title how many chars? lets see 123 ok more? yes 60

We have created lots of YouTube videos just so you can achieve [...]

Another post test yes yes yes or no, maybe ni? :-/

The best flat phpBB theme around. Period. Fine craftmanship and [...]

Do you need a super MOD? Well here it is. chew on this

All you need is right here. Content tag, SEO, listing, Pizza and spaghetti [...]

Lasagna on me this time ok? I got plenty of cash

this should be fantastic. but what about links,images, bbcodes etc etc? [...]