Having difficulties with Yousician Piano? Found a bug in the game? Post it here.
I'm using an M-audio KeyStudio midi keyboard (USB-connection) on a PC. I get the "Yousician was unable to start its audio system" message when I start Yousician. 1 out of 10 times it will recognize the input and work fine, but lately I cannot get it to work. My other music programs will recognize the keyboard and I can play in those.
I tried connection a Keystation Mini 32 too, and I still get the same error message.
Shortly after the error message Yousician will stop working and close down. I'm not able to configure the sound input from within the program.

I just upgraded to the Premium version and I'm very frustrated. What to do?


The keyboard should be a normal and supported MIDI device so something is definitely wrong. Just to check whether it's the MIDI or something else in the audio system that is failing:

- Does Yousician start normally, play songs and recognise notes with audio input if you start it without the MIDI keyboard plugged in?
- What happens if you plug in the keyboard when the program is already running? Normally it should detect a new MIDI device and suggest using it.

Also, do you have other programs running in the background that might interfere with the audio or MIDI handling?

Beyond that, it might be a good idea to contact support@yousician.com and to provide the startup logs so that we can take a closer look at what's happening there. They can help in locating the correct files to send. Let's try to figure this out. Regards,

Hi AnttiH,

Thanks for your answer.

Well now I made it work, and realized why it's only working some times.

When I start Yousician with a guitar plugged in (through a Rocksmith cable) as well as the midi keyboard, it works fine. When I launch it without the guitar connected and only the midi keyboard, it doesn't recognize the keyboard.
I was facing same issue, it has nothing to do with midi, it's audio problem
while investigating I look into log file and saw the following in the middle

[Native] * Windows Audio:
Input devices:
Output devices:
- Speakers (Realtek High Definition Audio)
- Realtek Digital Output (Realtek High Definition Audio)
Input devices:
Output devices:

(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)
[Native] Unable to switch to devices and Speakers (Realtek High Definition Audio)
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

this would seem as like it tries to use audio input but since I don't have any (I use midi input) some code fails and nothing else works. =)
I plugged in a microphone into input jack and that fixed it.

Hope you'll fix it, I won't keep mic here plugged in always.
Thank You so much for posting your fix! I was having the same issue (in 2019) and have gone over half the year with it not working! I built an entire new comp system to use, and it still did not work until I found your solution. This is still not fixed! so to recap if your midi keyboard (no matter how expensive) is not working, try plugging a microphone (even though you will not use it) into your system, so the audio system will load. Your MIDI will work fine after that.
I have facing the same problem. I have Realtek Audio Drivers. I had to connect a Microphone Cable to the Jack input to allow me to use Yousician. Please, correct this big Bug.
Microphone.jpg (777.97 KiB) Viewed 9843 times
Changes to songs??

Took a bit of a break and came back to start playi[…]