Having difficulties with Yousician Guitar? Found a bug in the game? Post it here.
By somersetsimon
I'm struggling with how Yousician interprets timing between different devices. To test, I've played a few simple level 3 songs that I knew I could play consistently. What I found was:

Acoustic guitar, Android tablet using built in mic - 100% perfect
Acoustic guitar, Android One2One phone using built-in mic - 100% late
Electric guitar, Android tablet using built in mic - 100% perfect
Electric guitar, Android tablet using direct connection with iRig UA - 100% early

Any idea what's going on? I'm pretty sure it's not me. When I quickly switch between the electric guitar between iRig and mic and back, it goes from 100% early to 100% perfect to 100% early again. Is there some form of compensation or calibration built in that I don't understand?
By somersetsimon
No other comments on this? Am I the only one with this problem?
As an additional test I tried the iRig UA with my Android One2One phone. It showed everything as early. When I play the same guitar with the same device (but using the device mic) it shows everything as late!
Incidentally, when I plug the iRig UA into my Android devices, the settings still show the input device as being 'Device Microphone', rather than recognising the iRig.

If I had used this device the first time I used Yousician, I would have given the app as a waste of time.
By Antmax
What settings is your irig on. People on the PC who have interfaces found timing issues when they had their interface on a default recording with 24bit 96,000hz. When they went to settings and reduced to 44,000hz CD quality the timing was vastly improved.

Earlier this week someone mentioned a similar problem with their Rocksmith cable. So I mentioned the above plus the fact that my cable and rocksmith operate at 48,000hz DVD quality. They reduced it down to 44,000hz CD quality and said that it fixed their timing issue.

Your iRig might have similar settings. If so, try 16bit 44,000hz see if that fixes it.
By somersetsimon
The iRig UA is an Android device. The only thing on settings tab is a slider to change the input level.
By Antmax
Don't know. But a quick look at the specs for tyhe UA state Sampling Rate: 44.1 and 48 KHz. Since that was the same difference in which a rocksmith cable user noticed the delay, it might be what's causing your problem.
By Alexicutioner
Every device and interface handles audio with different amounts of latency. Unfortunately, there simply isn't much you can do unless Yousician implements a calibration feature.
By somersetsimon
Any input on this from the developers? I thought it would something that would interest them. If some devices have such a bad timing issue that someone might reject the app as useless, then surely that's worth looking at!
By Antmax
I've been talking to people on reddit about these things. The most common problem is the sampling rate. 44100 will give you the best result. A couple of people on Yousician reddit have had problems. And it's almost always the sampling frequency. Even the difference between 44k and 48k is noticeable and frustrates peoples timing. It gets worse with 96k.

In windows you can set the sample rate in microphone settings which can be found from the right click menu accessed from the sound icon on the taskbar next to the clock (under recording devices). USB cables show as microphones and you set their sample rate in the same place.
By somersetsimon
Thought I'd bump this again to try and get some response from the developers...

Hi, I am getting the same problem. Installed Yous[…]

Think I got lucky. Signed up for the 7-day trial […]

that is exactly my question too is it a bug or a l[…]

Turn down yousician music volume?

They did bring back the master volume some time ag[…]