Page 1 of 1

Video stuttering on slow connection

Posted: Tue Jun 23, 2015 5:55 am
by f3flight
Hi there Yousicians,

I am using Windows version of the app. I have just purchased a yearly plan to keep on learning and I've found that when on a slow internet connection, video starts stuttering heavily. Actually it is not the video, which pauses often, but audio which does not pause and starts stuttering instead. I would like to ask devs to fix this. I am currently uploading an example video taken with my cellphone which shows the issue, but you may probably know about it already. Let me know if you need it and I will provide a link.
Additionally, 2 features regarding video look necessary:
1. preload indicator - currently it is not possible to understand how much of the video has been downloaded
2. rewind possibility - currently it is not possible to rewind, it is only possible to close and reopen video to watch it again from the beginning.

Re: Video stuttering on slow connection

Posted: Tue Jun 23, 2015 3:39 pm
by AshishYadav
I too have the same problem. The video status bar keeps moving in spite of sound stutter and no video being played. The video stops playing when the video status bar reaches the end irrespective of the fact whether the video is still somewhere in the middle of playing. :roll:

Please enable video rewind. Also please enable the video to be saved to the device so that the unlocked video can be watched in a slow connection too.

Re: Video stuttering on slow connection

Posted: Tue Jun 23, 2015 4:41 pm
by f3flight
Here's a video example showing the issue - https://drive.google.com/file/d/0B7Gf-e ... sp=sharing

Re: Video stuttering on slow connection

Posted: Tue Jun 23, 2015 5:39 pm
by andrew.ys.bells
Hi! Thanks for the feedback and sorry for the inconvenience. I've forwarded the message and the video link to our developers, they will look into the issue. I'll keep you guys updated!

Re: Video stuttering on slow connection

Posted: Mon Jun 29, 2015 5:27 pm
by f3flight
UPD - Looks like the behavior has changed now - it takes more time for video to start playing but it does not stutter anymore. I am considering this issue solved, thanks!

Re: [SOLVED] Video stuttering on slow connection

Posted: Tue Jun 30, 2015 11:21 am
by andrew.ys.bells
Thanks for the update! Glad to hear that the problem is not there anymore!

Re: Video stuttering on slow connection

Posted: Tue Jun 30, 2015 9:45 pm
by f3flight
No actually I was too quick to tell this - the problem is still there - last 2 videos I played did stutter. Not at all that bad as in my uploaded video, just a second of stuttering almost at the beginning. Same diagnosis - audio starts playing immediately while screen is still black, then video catches up but soon after that is freezes for a moment with audio stuttering.

Re: Video stuttering on slow connection

Posted: Sat Jul 04, 2015 6:20 am
by f3flight
With new videos it starts stuttering close to the end of the video during a few lat seconds - so behavior has changed but problem is still there.

Re: Video stuttering on slow connection

Posted: Mon Jul 13, 2020 3:09 pm
by kysersosai
After alot of troubleshooting i learned that screen lag can be a result of refresh rate. So i changed my rate from 30hz to 60hz and Yousician is playing without stutter or lag.