Having difficulties with Yousician? Look here for help. Check the stickies first!
#15351
Hi, after two months or so (ok, not full time) I finally figured out how to use a wired headset in combination with my Fender SC X2 amp, Epiphone guitar and running Yousician on my PC (HP Omen, Win 10). You need to have a Fender amp that connects to your PC through USB. For q while I used the GUITQR LINK USB device in combination, with the ASIO4ALL drivers but after a while I think it stopped working properly, it generated parasite noise each time Yousician played a sound. I think it was the USB device’s poor quality. Reinstalling sound drivers/ASIO4ALL didn’t help. So out of the window it went. By coincidence I discovered how to do the set up ‘directly’. Here are the steps I went through, for what it's worth.
Connections:
1. Guitar to Fender amp (I'm using wireless transmitter / receiver units, found on www.wish.com). Advantage over a guitar cable: no more humming noise
2. Download and install (obviously) the Fender FUSE app. Once installed it should recognize the amp and connect automatically to it. This app works for all Fender amps with USB connection.
3. Download and install the latest ASIO4ALL 2.14 drivers. Don’ try and start these, it will automatically be done by the software that’s using it, in this case Yousician. And normally you don’t need to go in the ASIO
At this point you can already use the connection to record with software like Audacity, but that’s not our goal today
4. connect guitar to the amp, switch on the Fender amp, start FUSE and make sure they are connected
Start Yousician, click on the setup icon on home page. Then click on ADVANCED SETTINGS. If you have done the above properly, two drivers show: WINDOWS AUDIO and ASIO. Click on ASIO
5. Click on input device ‘ASIO4ALL’ and input channel Super Champ X2 Amp1 or Super Champ X2 Amp1. Try both, for me only Amp 1 works: strum your guitar and watch the indicator light on the upper right hand side light up, the more lights, the louder Yousician hears you. IMPORTANT: keep the buffer size as small as possible, the bigger, the more delay between hitting a string and actually hearing it. More me, a buffer size of 64, the lowest, is the best. I have a high end PC so no problem on that side.
6. At this point, Yousician hears my guitar but I still didn’t heard it over the headphones (nor over the speakers). For instance, going into the tuning selection, and playing one string after the other, Yousician does it’s work… except that I didn’t hear the guitar on my headphones…
7. I finally discovered why, and here’s perhaps what Yousician should improve: open a song but don’t play it yet. First, click on pause and then when the bar on the left hand side opens, click on MIXER. For the sake of this set up, choose ‘Clean’ and you’ll notice the volume is at 0. When you move it up all of a sudden you can hear the guitar. You can adjust the gain level and don’t forget to calibrate. Here’s where you need to strum as hard as possible, great to let you your frustration.
8. Close it and restart the song. Voila, now I have my guitar connected to the Amp, the amp connected to FUSE, FUSE/AMP connected to Yousician and the headphones connected to the PC. I hear Yousician, I hear the guitar and my family doesn’t hear anything, so we are all happy.

If you want you can open the ASIO4ALL control panel while Yousician is running. You can find it’s icon, a green square with an arrow pointing to the right inside. You can find it somewhere on the taskbar. For me, it shows 3 devices: SuperChamp, RealTek High Def Audio (that’s my PC’s audio, you might have another one, and HP 720p HD Monitor webcam. Only the first 2 are active, I can activate the third one as well but then it will also use the build I web cam micro. No need.

Ok, it works for me. Will it work for you? No promises. I don’t know your PC, your configuration etc. etc. Don’t turn to me with difficult configuration questions. What worked for me was trying trying trying… and discovering. I hope this works for you as well. Happy playing and rock on!!
#15366
I gave up using Windows as it can be very glitchy with these programs. Here is what I use.

I use a Lenovo Tab 4 and Yousician works awesome with it. My setup is this, an iRig 2 running into the headphone jack on the tablet, from the iRig 2 the 1/4 cable out to my Orange amp and the headphone audio out to my Orange AUX in. Excellent recognition in Yousician and I can hear my guitar clearly through the amp along with the output of Yousician for the backing track (so to speak), Works equally well with the bass in my Fender Rumble amp.
#15532
I'm also using my Fender Amp (Mustang II) via USB.
Took me a while to get it to work.

Did't have the problem with the headphones. I connected the computer and the amp via AUX (computer out, amp in)
Headphones go into the Amp. With this setting I can also play without headphones, hearing yousician and guitar through the amp
Windows 10 install fails

The same here :/ The Installation is only possibl[…]

Custom songs

ToneLib Jam/or Rocksmith with Rocksmith files from[…]

Tuner gone nuts

After the update today the tuner on yousician on m[…]

Please linux support :| Since someone still car[…]